IPB


Welcome Guest ( Log In | Register )

 Forum Rules Forum Rules
 
Reply to this topicStart new topic
> problem with textures and streets
schwarzermann0815
post Feb 20 2011, 23:12
Post #1


New Member
*

Group: Members
Posts: 7
Joined: 20-February 11
Member No.: 8,797




heyho!

i just startet building islands for arma. at the moment i'm a little frustrated because since i started i always had problems but i could solve them with the help of tutorials and forums, but now i got 2

problems i am really unable to solve.

1. problem with textures: i stuck to the tutorials i found, at least that's what i think. the problem is: i make the sat map and the layer mask. i copied the textures of the samplemap in the "data" folder of

my own island. i importet the sat map and layer mask in visitor, start buldozer and it converts everything as it should. in buldozer i can see the textures but now the problem: i use binpbo and make a pbo

file, then i start arma, start the editor and choose my island and when it finished loading i get the message: "cannot load material insel/data/layers/....rvmat" i can put units on the map but when i go on

"preview" the island is white (when i move i leave traces, if that's important). i read the txt file binpbo makes but it doesnt make me any smarter. it says:

Error reading text file 'island\data\layers\p_009-004_n_n_l03.rvmat'
C:\Program Files (x86)\Bohemia Interactive\Tools\BinMake\CfgConvertFileChng\CfgConvertFileChng.exe returned error 1

and that for every rvmat files (didn't count but i guess there is an entry for all of them)

2. problem with streets: i cant import some of the streets in visitor. working streets are: asf, ces, ces_d, kos, sil, silnice_mesto. not working are: asfaltka, silnice, samzat. when i try to get those not

working in visitor i get the message: "object doesn't follow requirements for road object. (Are there all named points present?)"

i hope i didnt confuse anybody with my writing, its enough that i am already confused but maybe somebody here can help me out!? i couldnt find anything in any forum that could help me and i really dont know

what i possibly could have done wrong...
if you need to know anything, just say wink.gif i'd like to help you helping me wink.gif

greetings
 
Quote Post
Old Bear
post Feb 21 2011, 17:18
Post #2


Forum Addict
Group Icon

Group: Administrators
Posts: 875
Joined: 6-November 06
From: Provence, France
Member No.: 20



I will try to help on the 1st issue : the texture problem

So you are having something like that :

P: > buildingspacename > yourmap > Source + Data + yourmap.cfg+ yourmap.wrp

In "yourmap" directory , 2 subdirectories Source and Data

In Source :
Terrain [in this directory: yourmap_Terrain, yourmap.pbl, yourmap_Sat, yourmap_Mask, yourmap.pew
Layers.cfg
mapLegend.png

In Data
Layers [the content of this directory is built by Visitor]
yourmaptexture1.RVMAT
yourmaptexture1_detail_co.paa
.... [all textures listed here]


After building the terrain in Visitor, having set the right parameters, have a look at the "Project Prefences" option in the Tools menu and set the "folder - textures" box as :

P:\buildingspacename\yourmap\data

Then select the "import Satellite+Mask ..." option in the Tools menu open Source directory click on layers.cfg, choose Rvmat selection as binary, then click to select yourmap_Sat.png and afterwards yourmap_Mask.png . Doing so you are associating colours from the mask and texture to sat picture, the result will be in Data > Layers directory.

When it's done click the "!" button to open Buldozer and wait until the process is finished ....







--------------------
 
Quote Post
schwarzermann0815
post Feb 21 2011, 18:14
Post #3


New Member
*

Group: Members
Posts: 7
Joined: 20-February 11
Member No.: 8,797



thanks for your help!
but the things you told me, i already did this way and this is working fine wink.gif
as is said, i can see the textures in buldozer but after i made a pbo i cant see the textures in the game.
but maybe (im not sure yet) i found a solution myself. i un-checked "binarize" when i use binpbo and now the textures are in visible in the game! but i dont really know if thats a good solution because i dont really know what this "binarize" does. so are there any negative effect when i un-check this option?

and after i solved this problem, a new one appeared wink.gif and because i dont want to open another new topic i'll post it here. i tried to create some own detail textures but it doesnt work. buldozer crashes everytime i start it and it beginns to convert. when i use the textures of the sample map everything works fine. of course i changed everything (paths etc.) in the layers.cfg and the config files of the textures so i really dont have a clue (again ;P) what i did wrong. so my question is, is there any tutorial on only creating the detailtextures?

thanks again!
greetings
 
Quote Post
Old Bear
post Feb 22 2011, 01:44
Post #4


Forum Addict
Group Icon

Group: Administrators
Posts: 875
Joined: 6-November 06
From: Provence, France
Member No.: 20



I must insist a bit on the file structure on your P: because what happens while binarizing is related to the location of your textures in the Data directory

I am not able to explain why, but I will suggest to have a look at Synide ArmA Build Environment document.

You must have such structure :

P:\work\yourprojectname\data

or on my own P:

P:\OLDBR\Yapal\data

For I am using my own TAG to name my working space


If not, the path to the texture will be lost during binarization.

On the texture editing topic , well, I am using The Gimp to edit the texture I am using on my maps and it works quite well.
Open the .paa texture with TexView, save it as .tga, change it as you want , save it as .tga in The Gimp you will have to untick the RLE compression box, then open the edited .tga file with TexView and save it as .paa.


--------------------
 
Quote Post
schwarzermann0815
post Feb 22 2011, 20:53
Post #5


New Member
*

Group: Members
Posts: 7
Joined: 20-February 11
Member No.: 8,797



i really appreciate your help! thank you!
but i still have the same problem and i checked everything 10 times now...
but maybe i didnt see my mistake so lets make it slow:
my folders are:

p:\gerni\grimsey\

in that folder i have two folders (data + source), "grimsey.wrp" and "config.cpp"

in the source folder is another folder named terrain, "grimsey.pew" "layers.cfg" "maplegend.png"

"sat_lco.png" and "mask_lco.png"
in the "layers.cfg" i wrote(for testing im just using two textures):
class Layers
{

class pisek
{
texture = "gerni\grimsey\data\pisek_mco.png";
material="gerni\grimsey\data\pisek.rvmat";
};

class mesto2
{
texture = "gerni\grimsey\data\mesto2_mco.png";
material="gerni\grimsey\data\mesto2.rvmat";
};

};

class Legend
{
picture="gerni\grimsey\Source\mapLegend.png";
class Colors
{
/// color names should correspond to surface layer names
pisek[]={{255,255,0}};
mesto2[]={{5,3,0}};
}
};


now the data folder:
the folder "layers" and:
"mesto2.rvmat" "mesto2_detail_co.paa" "mesto2_detail_co.png" " "mesto2_detail_nohq.paa"

"mesto2_detail_nohq.png" "mesto2_mco.paa" "mesto2_mco.png" (the same pisek files)

in the rvmat file i wrote:
ambient[]={0.900000,0.900000,0.900000,1.000000};
diffuse[]={0.900000,0.900000,0.900000,1.000000};
forcedDiffuse[]={0.020000,0.020000,0.020000,1.000000};
emmisive[]={0.000000,0.000000,0.000000,0.000000};
specular[]={0.000000,0.000000,0.000000,0.000000};
specularPower=1.000000;
PixelShaderID="NormalMapDiffuse";
VertexShaderID="NormalMapDiffuseAlpha";
class Stage1
{
texture="gerni\grimsey\Data\mesto2_detail_nohq.png";
uvSource="tex";
class uvTransform
{
aside[]={10.000000,0.000000,0.000000};
up[]={0.000000,10.000000,0.000000};
dir[]={0.000000,0.000000,10.000000};
pos[]={0.000000,0.000000,10.000000};
};
};
class Stage2
{
texture="gerni\grimsey\Data\mesto2_detail_co.png";
uvSource="tex";
class uvTransform
{
aside[]={10.000000,0.000000,0.000000};
up[]={0.000000,10.000000,0.000000};
dir[]={0.000000,0.000000,10.000000};
pos[]={0.000000,0.000000,10.000000};
};
};


but i guess here everything should be okay, because i just copied the whole stuff from the samplemap and

just changed the pathes in the rvmat files.

the layer folder is empty until i start buldozer, then it is filled automatically, as you said.

the config.cpp in the grimsey folder is: (not the whole, i deleted the gras and stone etc entries to keep

it short here. but i think i cannot do anything wrong with them, can i?!)

#define TEast 0
#define TWest 1
#define TGuerrila 2
#define TCivilian 3
#define TSideUnknown 4

#define true 1
#define false 0

// type scope
#define private 0
#define protected 1
#define public 2

#define ReadAndWrite 0 //! any modifications enabled
#define ReadAndCreate 1 //! only adding new class members is allowed
#define ReadOnly 2 //! no modifications enabled
#define ReadOnlyVerified 3 //! no modifications enabled, CRC test applied

class CfgPatches
{
class grimsey
{
units[] = {grimsey};
weapons[] = {};
requiredVersion = 0.10;
requiredAddons[] = {CAData,CABuildings,CAMisc,CAPlants,CARoads,CARocks};
};
};


class DefaultLighting;
class DefaultLighting_CA : DefaultLighting {};

class CfgWorlds
{

class DefaultClutter
{
scaleMin = 0.9;
scaleMax = 1.4;
};
class DefaultWorld;
class CAWorld : DefaultWorld
{
class Grid {};
};

class grimsey: CAWorld
{
access = ReadOnlyVerified;
worldId=3;

cutscenes[] = {grimseyIntro1};

description = "Grimsey";
icon="";
worldName=\gerni\grimsey\grimsey.wrp;
pictureMap = "";
pictureShot = "";

plateFormat="ML$ - #####";
plateLetters="ABCDEGHIKLMNOPRSTVXZ";

longitude = -40; // positive is east
latitude = -40; // positive is south

// landRange is stored directly in WRP file

class Grid : Grid
{
offsetX = 0;
offsetY = -15360;

class Zoom1
{
zoomMax = 0.5;
format = "XY";
formatX = "Aa";
formatY = "00";
stepX = 200;
stepY = 200;
};
class Zoom2
{
zoomMax = 1e30;
format = "XY";
formatX = "A";
formatY = "0";
stepX = 2000;
stepY = 2000;
};
};

startTime = 8:30;
startDate = 01/05/1985;
startWeather = 0.1;
startFog = 0.0;
forecastWeather = 0.3;
forecastFog = 0.0;

seagullPos[] = {1272.842,150.000,14034.962};

//default center position
centerPosition[] = {2500,2500,300};

// landing place - airport
ilsPosition[] ={2545,3000};
ilsDirection[] ={0,0.08,1};
ilsTaxiIn[]= {2495,2725, 2495,2850, 2508,2860, 2508,3000, 2520,3010, 2545,3000};
ilsTaxiOff[]= {2545,2445,2520,2425,2495,2445,2495,2725};
drawTaxiway=false;


class CfgWorldList
{
class grimsey {};
};



then i use binpbo. i tried 4 different things with it:

1: addon source directory: p:\gerni (with binarize)
the island is in the editor map list but when i load it i get the message i posted before. the binpbo txt

tells me:
gerni\grimsey\data\layers\s_000_000_lco.paa->C:\Users\Admin\AppData\Local\Temp\ARMAaddons\gerni\grimsey

\data\layers\s_000_000_lco.paa
goes untill s_005_005_lco and the same with m_000_000_lco.paa
then the errormessages start:
Error reading text file 'gerni\grimsey\data\layers\p_003-005_l01.rvmat'
C:\Program Files (x86)\Bohemia Interactive\Tools\BinMake\CfgConvertFileChng\CfgConvertFileChng.exe

returned error 1
i also get errors for grass and rocks for example:Error reading text file 'ca\rocks\data

\stone3_clutter.rvmat'
C:\Program Files (x86)\Bohemia Interactive\Tools\BinMake\CfgConvertFileChng\CfgConvertFileChng.exe

returned error 1
the last lines in the text file are:
Convert world p:\gerni\grimsey\grimsey.wrp -> C:\Users\Admin\AppData\Local\Temp\ARMAaddons\gerni\grimsey

\grimsey.wrp
Singular mapping: #(argb,8,8,3)color(0,0,1,1), u 3529.48 x v 2544.33, AoT 1600
W:\c\Poseidon\Lib\fileServer.cpp(2010) : Assertion failed '_workerThread.Size() == _nRequestsLoading'

2: addon source directory: p:\gerni (without binarize)
the island is in the editor map list and it works, i can see the textures ingame
the binpbo txt file is completely empty

3: addon source directory: p:\gerni\grimsey (with binarize)
the map does not appear in the map list of the editor. the binpbo txt file is full again. this time with:

Parse: 0 ms
Cannot load font core\data\fonts\lucidaconsoleb8
Fonts file \core\data\fonts\lucidaConsoleB8 not found
Cannot load font core\data\fonts\lucidaconsoleb11
Fonts file \core\data\fonts\lucidaConsoleB11 not found
Cannot open object core\default\default.p3d
Cannot open object core\skyobject\skyobject.p3d
Cannot load font core\data\fonts\tahomab16
Fonts file \core\data\fonts\tahomab16 not found
Cannot open object ca\plants\clutter_grass_general.p3d
Cannot open object ca\plants\clutter_grass_flowers.p3d
Cannot open object ca\plants\clutter_grass_long.p3d
Cannot open object ca\plants\clutter_grass_sevenbaeuty.p3d
Cannot open object ca\plants\clutter_grass_yellow.p3d
Cannot open object ca\plants\clutter_grass_desert.p3d
Cannot open object ca\plants\clutter_forest_fern.p3d
Cannot open object ca\rocks\clutter_stone_small.p3d
Cannot open object ca\plants\clutter_smetanka.p3d
Cannot open object ca\plants\clutter_white_flower.p3d
Cannot open object ca\plants\clutter_horcak.p3d
Cannot open object ca\plants\clutter_prasivky.p3d
Cannot open object ca\plants\clutter_babka.p3d
Cannot open object ca\plants\clutter_muchomurka.p3d
Cannot load material file gerni\grimsey\data\layers\p_000-000_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-000_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-000_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_003-000_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_004-000_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_005-000_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_000-001_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-001_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-001_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_003-001_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_004-001_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_005-001_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_000-002_n_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_000-002_l00_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_000-002_l00_n.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-002_n_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-002_l00_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-002_l00_n.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-002_l00_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-002_n_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_003-002_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_004-002_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_005-002_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_000-003_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-003_n_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-003_l00_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-003_n_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-003_l00_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_003-003_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_004-003_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_005-003_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_000-004_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-004_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-004_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_003-004_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_004-004_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_005-004_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_000-005_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_001-005_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_002-005_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_00Convert world p:\gerni\grimsey\grimsey.wrp -> C:

\Users\Admin\AppData\Local\Temp\ARMAaddons\grimsey\grimsey.wrp
3-005_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_004-005_l01.rvmat
Cannot load material file gerni\grimsey\data\layers\p_005-005_l01.rvmat

3: addon source directory: p:\gerni\grimsey (without binarize)
the map does not appear in the map list of the editor. the binpbo txt file is empty.


at the moment i have no idea of what to try to get it work or wich information i can give you that could

help you helping me...

for now i will have a break and watch tv for a while :S
but thanks again!
 
Quote Post
Old Bear
post Feb 24 2011, 09:46
Post #6


Forum Addict
Group Icon

Group: Administrators
Posts: 875
Joined: 6-November 06
From: Provence, France
Member No.: 20



QUOTE
the config.cpp in the grimsey folder is: (not the whole, i deleted the gras and stone etc entries to keep it short here. but i think i cannot do anything wrong with them, can i?


Hell !
Of course you can do wrong
because :
1 you must define in the config the plants you are going to use in the clutters , in in the "World" part

QUOTE
class trop_GrassTall : DefaultClutter {
model = "ca\plants2\clutter\c_grassDryLongBunch.p3d";
affectedByWind = 0.4;
swLighting = 1;
scaleMin = 0.5;
scaleMax = 0.75;
};


2 you must define the clutter in the "SurfaceCharacters" part as :

QUOTE
class trop_HillClutter {
probability[] = {0.2, 0.1, 0.3, 0.2};
names[] = {"trop_Stubble", "trop_WeedDead", "trop_GrassDryBunch","trop_GrassTall"};
};


3 you must define the texture/clutter association in the "Surfaces" part as :

QUOTE
class trop_mesto2 : Default {
access = ReadOnly;
files = "trop_mesto2_*";
rough = 0.0;
dust = 1.0;
soundEnviron = "dirt";
character = "trop_HillClutter";
soundHit = "soft_ground";
};


So, ... it's on my Tropica island, you have a "trop_GrassTall" being a part of the "trop_HillClutter" which in turn is associated to the " trop_mesto2" texture, et voilÓ !


Have also a look at you BinPbo configuration : here is an interesting topic on the Visitor 3 thread on the BI Forums.

And here is the pic I am using myself to configure BinPbo after a clean re-install :



--------------------
 
Quote Post
schwarzermann0815
post Feb 28 2011, 02:29
Post #7


New Member
*

Group: Members
Posts: 7
Joined: 20-February 11
Member No.: 8,797



merci beaucoup for everything so far!

one thing i should have mentioned: i tried to get the samplemap in the game and i had the same problem that i had with my own. i also took the entries for the plants etc. from the samplemap and they showed up when i didnt binarize the map...

BUT i got my copy of arma II on friday and the first thing i did (even before i played the game) i tried to get my map in the game and it worked just perfectly! even with the selfmade textures (of course not the plants but i just have to change the entries in the config file for that). please dont ask why it works with arma 2, because i have absolutly no idea!!! i didnt do anything diffently (well, at least i think so).
so i will play through the game in the next time and then i will move on to the arma 2 forum, so you wont lose me wink.gif (because actually i have fun again with making islands)

so thank you again, and see you later, guess wink.gif
 
Quote Post

Fast ReplyReply to this topicStart new topic
3 User(s) are reading this topic (3 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 24th October 2017 - 11:56